Homepage Wiki Forum Buy

GNUBLIN embedded GNU/Linux

Open source learning and training plattorm for embedded GNU / Linux
A projects from Hochschule Augsburg and embedded projects GmbH

Project homepage: http://www.gnublin.org
Wiki: http://wiki.gnublin.org
Aktuelle Zeit: Fr 24. Nov 2017, 16:44

Alle Zeiten sind UTC + 1 Stunde [ Sommerzeit ]




Ein neues Thema erstellen Auf das Thema antworten  [ 49 Beiträge ]  Gehe zu Seite Vorherige  1, 2, 3, 4, 5  Nächste
Autor Nachricht
 Betreff des Beitrags: Re: Funktionierende Wlan Hardware
BeitragVerfasst: Mo 2. Jul 2012, 13:45 
Offline

Registriert: Di 10. Apr 2012, 12:23
Beiträge: 35
Hallo,

ich wollte noch anmerken, dass die WLAN Adapter mit dem Chip RTL8192S (z.B. der Asus WL-167G V3)
bei einem normalen 2.6.33 Kernel tatsaechlich nicht funktionieren. Ich habe dazu vor Monaten aus dem
2.6.39 Kernel das Verzeichnis drivers/staging/rtl8712/ "gestohlen" und in den Gnublin Kernel eingebaut.
Das Kernelmodul heisst dann r8712u.ko. Man braucht auch die Firmware r8712u.bin, die bei mir in
/lib/firmware/rtlwifi liegt.

Der Quelltext ist in meinem Kernel

http://elk.informatik.fh-augsburg.de/cg ... ;a=summary

eingebaut. Clonen kann man den Kernel mit

git clone git://elk.informatik.fh-augsburg.de/srv ... 2.6.33.git

Ich glaube, dass Benedikt alle ausgelieferten MicroSD Karten schon mit diesem Treiber ausstattet.

Gruesse,

Hubert


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Funktionierende Wlan Hardware
BeitragVerfasst: Mo 2. Jul 2012, 20:18 
Offline
Moderator

Registriert: So 8. Apr 2012, 09:01
Beiträge: 108
Hallo Hubert,

Habe den Treiber von Realtek (RTL819xSU_usb_linux_v2.6.6.0.20120405) benutzt, laut Doku lauft er seid 2.6.18.

Aber dir Produkt-ID der Netzwehrkarte ist nicht im Treiber verfügbar.

Und über den Chipsatz der Karte gibt es mehrere Aussagen (rtl8192 oder rtl8188).

Gruß Dominik

Werde mir euren mal anschauen ;)

Sind aber nicht sehr viel Sticks vorhanden.
Habe dir 0b05:1791 des Asus auch nicht gefunden. :shock:

_________________
Lieber ein Pinguin der läuft, als ein Fenster, das hängt...


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Funktionierende Wlan Hardware
BeitragVerfasst: Mi 4. Jul 2012, 09:46 
Offline

Registriert: Mi 4. Jul 2012, 08:24
Beiträge: 4
Hallo @ all,

ich habe erst seit ein paar Tagen das Board und habe auch ein paar Fragen zum WLan.
Hoffe, das passt hier!

Das WLan habe ich nach der App-Note zwar zum Laufen bekommen, nur habe ich noch zwei Probleme.

1. bekomme die Verbindung zum Router nur hin, wenn ich auf diesem die SSID sichtbar schalte.
Im Normalfall habe ich das nicht.

2. beim pingen zu einem Rechner in meinem Netz oder zum Internet, gehen immer wieder Pakete verloren.

Ich hoffe, es kann mir jemand bei meinem Problem helfen.

Gruß
Frank


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Funktionierende Wlan Hardware
BeitragVerfasst: Mi 4. Jul 2012, 11:40 
Offline

Registriert: Sa 2. Jun 2012, 07:38
Beiträge: 52
Hallo Frank
Vielleicht geht es mit dem Router so:
iwconfig wlan0 essid any
Zu dem Paketverlust weiss ich nix.
Rumprobieren: Einmal ganz nah an den Router ran um rauszufinden ob es am Funkempfang liegt.
Dann erst in der Software weitersuchen

Gruss Egon


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Funktionierende Wlan Hardware
BeitragVerfasst: Mi 4. Jul 2012, 15:08 
Offline

Registriert: Mi 4. Jul 2012, 08:24
Beiträge: 4
Hallo Egon,

erst einmal Danke für die schnelle Hilfe.
Man mag es kaum glauben, aber "iwconfig wlan0 essid any" hat etwas "unerwartetes" bewirkt.
Jetzt habe ich keine Verbindungsabbrüche mehr. :?
Aber eine Verbindung, wenn die Sichtbarkeit der SSID ausgeschaltet ist, klappt immer noch nicht.
Wenn ich bei laufender Verbindung die Sichtbarkeit ausschalte, bleibt die Verbindung hängen.
Schalte ich die Sichtbarkeit wieder ein, läuft die Verbindung von allein wieder an.
Vielleicht noch ein paar Randbedingungen.
Ich habe die Fritzbox 7270 und die Verbindung habe ich über WPA2 eingerichtet.

Gruß
Frank


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Funktionierende Wlan Hardware
BeitragVerfasst: Mi 4. Jul 2012, 19:57 
Offline

Registriert: Sa 2. Jun 2012, 07:38
Beiträge: 52
Hallo Frank

Nächster Versuch wär eine feste IP für Gnublin.
Die nächsten Zeilen sind natürlich Quatsch, wenn Du schon eine feste IP haben solltest.
Aber was anderes fällt mir so aus dem Stand nicht ein.

zb.

ifconfig wlan0 192.168.1.7

Default Gateway einrichten:
route add default gw 192.168.1.1

Einen Namensserver Gnublin bekannt geben:
cat /etc/resolv.conf
echo "nameserver 192.168.0.1" >> /etc/resolv.conf

Oder einen öffentlichen Nameserver wie den von Google:
echo "nameserver 8.8.8.8" >> /etc/resolv.conf

(kopiert aus dem Gnublin Wiki)

Gruss Egon


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Funktionierende Wlan Hardware
BeitragVerfasst: Mi 4. Jul 2012, 20:11 
Offline

Registriert: Sa 2. Jun 2012, 07:38
Beiträge: 52
Hallo Frank
hab noch was gefunden
iwconfig wlan0 ap 00:60:1d:01:23:45 <-------- MAC Adr. vom Router
ob
iwconfig wlan ap Ro.ut.er.IP < Router IP
geht weiss ich nicht.
Kuck einfach mal

Gruss Egon


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Funktionierende Wlan Hardware
BeitragVerfasst: Mi 4. Jul 2012, 20:31 
Offline
Moderator

Registriert: So 8. Apr 2012, 09:01
Beiträge: 108
Hallo,

@Egon Läuft der Treiber in dem Kernel jetzt stabil ???

@ll Wenn ihr eine IP per dhcp bekommen möchtet.
Code:
udhcpc -i wlan0


Gruß Dominik

_________________
Lieber ein Pinguin der läuft, als ein Fenster, das hängt...


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Funktionierende Wlan Hardware
BeitragVerfasst: Mi 4. Jul 2012, 21:03 
Offline

Registriert: Sa 2. Jun 2012, 07:38
Beiträge: 52
Hallo Dominik
Der letzte vom 01.07 18 Uhr 43 hab ich nicht zum Laufen bekommen.
Der davor 01.07 14 Uhr 15 der funktionierte.
Zeigte aber jede Menge Meldungen an, bevor er IP und Wlan Einstellungen übernommen hat.

Gruss Egon


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Funktionierende Wlan Hardware
BeitragVerfasst: Mi 4. Jul 2012, 21:38 
Offline

Registriert: Mi 4. Jul 2012, 08:24
Beiträge: 4
Hallo Egon,

habe alles versucht, kein Erfolg :x
Mit "versteckter" SSID will einfach keine Verbindung zustande kommen.

Dann muss ich die wohl oder übel sichtbar lassen.
Oder es geschieht noch ein Wunder. :)

Gruß Frank


Nach oben
 Profil  
 
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen Auf das Thema antworten  [ 49 Beiträge ]  Gehe zu Seite Vorherige  1, 2, 3, 4, 5  Nächste

Alle Zeiten sind UTC + 1 Stunde [ Sommerzeit ]


Du darfst keine neuen Themen in diesem Forum erstellen.
Du darfst keine Antworten zu Themen in diesem Forum erstellen.
Du darfst deine Beiträge in diesem Forum nicht ändern.
Du darfst deine Beiträge in diesem Forum nicht löschen.
Du darfst keine Dateianhänge in diesem Forum erstellen.

Suche nach:
cron
Powered by phpBB® Forum Software © phpBB Group
Deutsche Übersetzung durch phpBB.de